CALL US: 1-800-445-0624
Showing: 1-6 of 6  
Articles
 
document ETS Units 2002 and Newer: Error 92
ERROR 92 The bed is off when it should be on. Current sensor indicating unit is off when it should be on. The contactor relay is not engaged, therefor the lamps will not come on. This can be caused by low power or by a faulty contactor relay.  Occasionally, it is caused by a...
rating 03 Jan, 2013 Comments: 0
document ETS Units 2002 and Newer: Error 93
ERROR 93  The bed is on when it should be off                Current sensor indicating unit is on when it should be off. If you see lamps on: This is usually caused by a stuck contactor relay. If you cycle...
rating 03 Jan, 2013 Comments: 0
document ETS Units 2002 and Newer: Error 98
Error 98 Bed temperature exceeded Allow the unit to cool Check all fan openings and air filter for obstructions. If problem persist, contact servicer. Verify the following items: Unit Operating voltage, room temperature. and fan operation. If all of these...
rating 03 Jan, 2013 Comments: 0
document ETS Units 2002 and Newer: Restore Factory Default Settings
If, for whatever reason, you need to restore your factory default settings you will want to set the bed address to 255 and cycle power to the unit. You will need to refer to the manual for your bed for the instructions on how to manually address your bed using the on bed controls. Before you...
rating 03 Jan, 2013 Comments: 0
document ETS Units: HP1000 "Display has lost communication with BCM Controller"
Display has lost communication with BCM Controller When the HP 1000 is installed, the installers must connect a series of computer network cables between a series of circuit boards in the unit. These must go in a specific order: BCM Board (the small board in the back tray), Audio...
rating 07 Jan, 2013 Comments: 0
document ETS Units: Trouble addressing the bed.
My bed is connected to a T-Max remote system but I am having trouble addressing the bed from the bed controls. You have probably attempted to connect you tanning bed to the remote system already.  Disconnect the remote plug(s) from the ports on the input box, wait 90 seconds or...
rating 03 Jan, 2013 Comments: 0